PDA

View Full Version : Double Lightbox Issue



syedahmed
02-07-2013, 05:18 AM
Hi Guys,

So I just bought the plugin after using the lite version, I really want to keep the sortable gallery of this theme and the social gallery to open up the images, currently what happens is I get two lightboxes. Is there anyway to stop this from happening. http://zanedo.3lements.net/photos-2/

fotoglut
02-07-2013, 09:22 AM
Have you try this?
http://forum.socialgalleryplugin.com/showthread.php/36-Nextgen-plugin-and-this-plugin-both-showing-a-lightbox

woods
02-11-2013, 04:49 PM
Hi Guys,

So I just bought the plugin after using the lite version, I really want to keep the sortable gallery of this theme and the social gallery to open up the images, currently what happens is I get two lightboxes. Is there anyway to stop this from happening. http://zanedo.3lements.net/photos-2/

Hi syed,

As fotoglut has explained - did you try changing the option in NextGen?



Have you try this?
http://forum.socialgalleryplugin.com/showthread.php/36-Nextgen-plugin-and-this-plugin-both-showing-a-lightbox

Thanks for helping out fotoglut!

BazookaDigit
03-12-2013, 06:01 PM
I am having a similar issue. I am not using NextGen and the SG works just fine, but the native theme lightbox shows up as well.

Process is as follows --
Click Image thumb > SG shows up perfectly > close SG > lightbox from theme is there

How can I get rid of this second LB?

syedahmed
03-12-2013, 07:08 PM
It really depends on your theme, although we've made our own iframe box for the client, the way I got around it was that I found where the lightbox is executed from, in most cases its the header or the footer. I just simply erased the call for that function:

Example for this theme it was (its called Juxter) it was in the footer.php
$pwork_theme->lightbox_init(); //*Just completely erased this line from the file*//

Hopefully that should give you a bit of an idea as to what you're looking for, also run the plugin in compatibility mode when you're using a theme with its own lightbox.

syedahmed
03-12-2013, 07:15 PM
You can also try going into your themes directory and deleting the js file for your lightbox its usually prettyphoto or fancybox, these are usually stored in >> yourthemefolder/extends/js or yourthemefolder/js. Just make sure you back them up before deletion, use this if the above doesnt work out.

BazookaDigit
03-12-2013, 07:29 PM
Oh man... none of those worked!

I'm using Mingle as a theme. At one point, I had incorporated BuddyPress, but recently turned it off because we didn't want to do the forum thing anymore on the site. I have deleted the plugin and the files associated with it.

I'm still having the same issue. Check it out here -- http://scooterspost.com/archives/2608

cybohmoob
03-14-2013, 01:52 AM
Some themes love to take charge of LightBox as it's main loader. You have to comment off and disable them.

cybohmoob
03-14-2013, 01:56 AM
Oh man... none of those worked!

I'm using Mingle as a theme. At one point, I had incorporated BuddyPress, but recently turned it off because we didn't want to do the forum thing anymore on the site. I have deleted the plugin and the files associated with it.

I'm still having the same issue. Check it out here -- http://scooterspost.com/archives/2608

For RAZOR, SALUTATIONS, and MINGLE you can turn off the light box in the themes FUNCTION by doing the following.

/* theme_register_css( ‘colorbox’, $cssPath.’colorbox.css’ ); */

Find it searching for // Lightbox styles .



comment it off with /* code sample */ .

The code might look different but it's still has to /* theme_register_css( ‘', $cssPath.’code.css’ ); */ so just look carefully for the lightbox loader.

BazookaDigit
03-14-2013, 09:41 AM
For RAZOR, SALUTATIONS, and MINGLE you can turn off the light box in the themes FUNCTION by doing the following.

/* theme_register_css( ‘colorbox’, $cssPath.’colorbox.css’ ); */

Find it searching for // Lightbox styles .



comment it off with /* code sample */ .

The code might look different but it's still has to /* theme_register_css( ‘', $cssPath.’code.css’ ); */ so just look carefully for the lightbox loader.

I tried this as you instructed and now, when I click on an image, it opens up in the SG and then for some reason, the image itself appears above the entire site... shifting the site itself downward (appearing above the header, nav etc).

Suggestions?

cybohmoob
03-14-2013, 07:49 PM
That's pretty strange. LightBox and SG shouldn't have any effects on the web page's content positions.
Could you supply a snapshot?


Chances are that this is probably a Mingle issue. It's a Theme issue because Mingle, Salutations, and Razor use their own positioning, z-indexing and automatic page floats. Those may have changed or have an automatic effect on you having Social Gallery load the image.

If this don't work you might have to talk with Andy, Steve or Jeff about this at the Mingle Forums website. They need to tell you where the proper Mingle LightBox codes are located to properly disable the Mingle LightBox without interfering with the pages content.

BazookaDigit
03-14-2013, 08:19 PM
Oh man, ok. I just posted on the forum over there. Hopefully they can help figure it out.

When I get a solution, I will post it here for future users who might have the same issues!

Thanks for all your help!

cybohmoob
03-14-2013, 09:20 PM
Oh man, ok. I just posted on the forum over there. Hopefully they can help figure it out.

When I get a solution, I will post it here for future users who might have the same issues!

Thanks for all your help!

Yes no problem.
Hope you solve this.

If they can't either. Let me know so we can continue to debug the problem.
Maybe I can take a look at your php & css and see what's causing it.
Sometimes it's so silly and could be a simple little minor things causing a week long hunt to debug the issue.
Keep us updated.

BazookaDigit
03-15-2013, 07:35 PM
They weren't much help... just kind of told me that the native lightbox is "deeply embedded" and removing it would remove other functionalities of the them?

Anyway, I just did the update to the SG plugin hoping that would maybe (?) resolve the issue... it did not. And in fact, now the SG isn't even showing anymore! It's just the native lightbox.

Any help would be greatly appreciated! The site has a big event coming up on 3/23 and the site is really only up and running because the event pictures around found there... so getting this resolved asap is pretty vital.

Thanks!

cybohmoob
03-15-2013, 10:36 PM
Ok lets try a last resort trick.


INSIDE the CSS box.

Enter this.

#cboxOverlay { visibility:hidden; }

This will hide the default LightBox that's popping up.

If that don't work I think one of your lesser Gallery plugins or image plugins are the culprit and those plugins Java Script for the light box DIRECTORY has to be found and renamed to "FORCE" it to deactivate.

BazookaDigit
03-15-2013, 10:54 PM
INSIDE the CSS box.

Enter this.

#cboxOverlay { visibility:hidden; }

This will hide the default LightBox that's popping up.


I tried this with no luck! I'm unsure of how to do the other fix you recommended... can you maybe elaborate for me?

Also, the SG plugin isn't showing up at all still... just the native lightbox.

Here's the link to check it out -- http://scooterspost.com/archives/2719

BazookaDigit
03-15-2013, 10:57 PM
Also, the Mingle theme guys said this...

After you have removed the reference to the lightbox JavaScript file, open “assets/js/onLoad.js” and remove (or comment out) any reverences to the “colorbox” function. You’ll want to work with the file in “assets/js/source/onLoad.js” then apply the changes to the compressed file used by the theme.

But I am unsure of how to do this... any suggestions?

matthew
03-17-2013, 03:47 PM
Hi BazookaDigit,

Unfortunately we cannot help with theme customisations. The instructions your theme developer has provided are pretty straight-forward if you know what you are doing. If you're not comfortable making the changes above, you would need to hire a developer to make these changes for you.

Thanks,

Matthew

BazookaDigit
03-17-2013, 08:37 PM
The very least you could do is help me out figuring out why, when the plugin was updated, it no longer shows the SG gallery at all. It used to at least show the plugin (that was paid for) and now, after the update -- without any changes made -- it does not show at all.

matthew
03-17-2013, 11:06 PM
Hi BazookaDigit,

We would be more than happy to try and help you with your other issue. How did you update the plugin? We recommend de-activating the plugin, deleting the plugin files and then re-installing via your WordPress admin.

We've also made some changes to the 'Update Engine' please try running the update engine again after re-installing the updated version of the plugin.

Please come back to us if you're still experiencing problems.

Thanks,

Matthew

BazookaDigit
03-17-2013, 11:34 PM
Yes, that's how I had updated it. To be sure, I repeated the process. Now, when I go to set up the plugin, I get to the end of the setup wizard and at that point, no matter what I click, it just sends me back to the wizard again. I feel like I'm going bonkers or something...

matthew
03-17-2013, 11:47 PM
Okay, please bear with us. I will speak with Woody (the plugin author) and get him to look at this urgently for you. Thanks for your patience so far.

Matthew

BazookaDigit
03-18-2013, 12:04 AM
That would be awesome and I'd really appreciate it.

If you need to you can email me directly at meghan@bazookadigital.com

cybohmoob
03-18-2013, 08:46 AM
Ok here's the next possible step to take. Kinda semi drastic measure.

USE the FireFox inspection tool to find out the ENEMY lightbox's elements. Find it's Class Selector using the FireFox inspect tool. View lower bar showing all kinds of elements and grab the Furthest Right Elements Class Selector.

Next HIDE that entire Enemy Lightbox using CSS code in Theme's CSS file.
Add

.EnemyElements, .MoreEnemyElements, .EnemyClassSelector{
visibility:hidden;
}
I am talking hide the whole Rogue LightBox.
The trick is that the LightBox will still LOAD alongside SG once we get SG to use the enemy lightboxs class Selector.

We will USE the Rogue Class selector by entering it into the custom Class Selector option found in SG config.


Now your SG should load up and ride on that Rogue Selector like a guy riding on a surfboard on a wave.

The enemy LightBox should be invisible except the SG.

Simple trick works pretty well.

If you still can't do it just let me know and I can volunteer 30 mins of my time to setting up SG for you on your server.
My site is https://HmongLife.com . You can go try it out and see how I did it. It's riding off a Rogue lightBoxes CSS selector. It even works on User Gallery riding off BP Gallery css selector.

Gl and be patient. This cool LightBox is worth it:)

p.s. Sorry that the Mingle guys didn't bother to help you too.

cybohmoob
03-18-2013, 06:15 PM
Uninstall your SG.

LogInto your MYSQL.

Delete all the SG data.

Log in FTP and delete the ENTIRE SG folder.


Here's how

First. https://hmonglife.com/images/re-install1.jpg
Second. https://hmonglife.com/images/re-install2.jpg

Now re-install FRESH.

Then follow this.

http://forum.socialgalleryplugin.com/showthread.php/145-Letting-SG-use-the-DEFAULT-and-Second-LightBox-Class-Selectors-to-RUN

woods
03-25-2013, 03:16 PM
Hi All,

@cybohmoob - thanks very much for trying to help out here :)

@BazookaDigit - OK here's my input: The problem here really is your theme lightbox - as I'm sure your aware. This *may* be removable via commenting out 1.) The .JS javascript includes for the lightbox 2.) the .CSS CSS includes & any other references to the lightbox in the theme php files - but from what you've said it seems that'll be a challenge. It's a real shame when theme providers aren't helpful, or write themes which are not designed to be customisable or editable easily. For your reference I'll put the files you need to comment out, this may or may not work:



<link rel="stylesheet" type="text/css" href="http://www.scooterspost.com/wp-content/themes/parallelus-mingle/assets/css/colorbox.css" />

<script type='text/javascript' src='http://www.scooterspost.com/wp-content/themes/parallelus-mingle/assets/js/libs/jquery.colorbox-min.js?ver=1.3.16'></script>

And all colorbox references in this file....


http://www.scooterspost.com/wp-content/themes/parallelus-mingle/assets/js/onLoad.js


If removing these doesn't work and they (theme creators) aren't helpful I am afraid I can't really help. However I can certainly help with the change since the update.

Did you check your settings after the update? They should be pulled through correctly - especially if you installed the update the correct way (as Matthew suggested.) - however it should be the case of simply setting the "Mode" or Custom CSS selector you had setup before - there's not much difference in the core between v2.0 and v2.1, it's mostly added features and a few fixes - so settings shouldn't need changing.

Hope this helps.