View Full Version : Having Gallery Issue with Likes - Likes associated to page not image

01-13-2013, 01:51 AM
The likes are counted for all photos. It is bringing up the social gallery sharing on all photos on my website. all I need it for is one gallery.

if you "LIKE" one they all show you liked them). And when you comment it doesn't show the comment or like on the user facebook timeline. Am I missing settings somewhere?

Also it is linking all the photos on my site with the social gallery setting... how do I stop that?

2) Also is there a way to add a facebook share button with these?

01-16-2013, 02:03 PM
Hi Davidlh,

1st up, thanks for posting this on the support forums - I'll gladly help you get this sorted.

Can I ask - what setting do you have "Fallback URL" on (first page of settings) and do you have "Social Gallery Pages" enabled (also first page) - these two dictate what URL's your like's/comments will get attached too.

Regarding 2) (if you haven't already) please vote for the addition of a facebook share button on the feature requests page (http://forum.socialgalleryplugin.com/showthread.php/48-Feature-Requests-Vote-on-Features).


01-22-2013, 11:49 PM

I've got the same issue in my website (using WP3.2 / Social Gallery Plugin v1.4 pending of update/ NextGen Gallery).

I don't know if I can post here or have to edit a new thread.

I've got many photos on a WP page with NextGen Gallery.

For my photos, I upload it to my server. Next step with WP dashboard, I choose Add Gallery > Import Image Folder.

Next step, I can manage gallery in WP dashboard>Manage.

Social Gallery Mode is on : NextGen Compatibility Mode + Automatically disable NextGen Effect is enable.

1. When I like a photo with plugin, it likes all photos of the website, not the unique photo I like.
2. When I comment on a photo and publish it on Facebook, it doesn't show the photo I liked, but always shows the same featured image of the page.
3. When I comment on a photo and publish it on Facebook, the link is to the whole page, not to the photo.

Am I missing any steps? Should I update to v2.0 before resolving this issue?

01-23-2013, 06:44 AM
Hi MeliMeloMok,

Please do update to v2.0 - it has far more options for where likes + comments get associated, please do make sure you are familiar with the following BEFORE you update:


^^ V2.0 is far better at dealing with this situation, but you'll need to understand why.



01-23-2013, 05:11 PM
I'm on V2.0 and just tested something.
I liked one of my images and instead of liking the single picture, i apparently liked my page (for example www.xyz.com). Additionally i liked every picture in the whole Gallery.
This is, what's displayed on facebook, then: "Ben likes www.xyz.com on xyz.com" and the link's URL is www.xyz.com. Any ideas on that one?

01-30-2013, 06:26 AM
Hi Deepabysm,

This totally depends on setup. To get likes/comments to appear per image you need to have either: Social Gallery Pages enabled + working OR Social Gallery Pages disabled + a fallback of "Image URL" ... if neither of these two situations exist then it'll default to liking the page (or if you have it on "Page URL" under fallback URL)

You can read more about pages here:


Do let me know if you can't get that working....

01-30-2013, 10:19 PM
It does not work with Social Gallery Pages enabled (I don't really know, if they are actually working. I'm experiencing a bug in displaying the page (see here (http://benthies.de/social-gallery/little-thoughts)) which I guess is some CSS not working together with the gallery but idk.

So I disabled Social Gallery Pages and set Fallback URL Type to "Image URL". Then I liked one of my pictures but it did not seem to do anything. In fact, the like button turned to grey and I guess I was able to like single pictures. But sadly, facebook newsfeed did not show that I liked this picture..

So I did not really get that working.

02-06-2013, 06:23 AM
Yo Deepabysm,

I can tell you a fix for your gallery pages - as you have been helpful to Social Galley (I can't do this for everyone.)

If you go to your Social Gallery plugin and edit the file "templates/single-social-gallery-image.php", at line 60 (about a third of the way down the page) you'll see the following line:

<div id="primary" class="site-content">

... if you change that line to look like this:

<div id="primary" class="site-content" style="width:790px;float:left">

... and in your Social Gallery settings on the "General" settings under "Social Gallery Pages" enter "790" into the box next to "Social Gallery Page Width"

... that should fix your page layouts (it's because you have a quite customised theme, from WordPress original classes etc.)

So I disabled Social Gallery Pages and set Fallback URL Type to "Image URL". Then I liked one of my pictures but it did not seem to do anything. In fact, the like button turned to grey and I guess I was able to like single pictures. But sadly, facebook newsfeed did not show that I liked this picture..

This one is perhaps to do with a bug in v2.0 which doesn't correctly output app id's, or that facebook deals occasional with direct image liking differently. The best solution ultimately is Social Gallery Pages (http://www.socialgalleryplugin.com/social-gallery-pages/), so it'd be good to try and get that sorted!

Hope that helped!


02-08-2013, 04:12 PM
//edit: ok, i got this problem solved. The theme I use ('Mantra') had some php at the end of it's <head> tag, of which I don't know the actual point:

wp_head(); ?>
However, deleting this 3 lines lead to success :P

///edit: At least, this is what I thought. If you are using Mantra, don't delete that lines. Seriously don't. I have to find another way.

First of all, thanks a lot for that fix! It worked and I really do appreciate that. Although, when I'm liking a picture it still does not appear on facebook, but that may be a problem I made on my own, I don't really know actually.

Does Social Gallery set the Value for 'og:url' (referring to Facebook's OpenGraph, I am sure you are familiar with it) in any way? I set og:url to my start page which should be working, but as soon as I do it, Facebook's Object Debugger says "Object at URL 'http:/xyz.com/' of type 'article' is invalid because it specifies multiple 'og:url' values: http://xyz.com/, http://xyz.com/."
Given the fact, that I included og:url only once, I was wondering, if Social Gallery includes this tag as well.

By the way, if I remove the og:url tag (located in the header.php file), the object debugger displays 'Object at URL 'http://xyz.com/social-gallery/imageurl' of type 'article' is invalid because the given value '' for property 'og:url' could not be parsed as type 'url'.

I just want to know if Social Gallery sets a value for og:url. If not, i need to search for the bug somewhere else.
Thank you!

//edit: I think it has something to do with the last update of my theme. Before it, opengraph did not complain after all.

02-11-2013, 05:53 PM
Does Social Gallery set the Value for 'og:url'

... yes it does - for Social Gallery pages. You might have to disable this if your having dupe issues.

Glad your getting there with fixes, please do keep us posted!


02-11-2013, 11:44 PM
I now uploaded the original and unedited header.php to my server so I can exclude any issues regarding manual meta properties settings. The error is the following:

Object Invalid Value: Object at URL 'http://benthies.de/social-gallery/little-thoughts' of type 'website' is invalid because the given value '' for property 'og:url' could not be parsed as type 'url'.
So If Social Gallery sets a value for og:url, why am I getting an error like the one above?

/edit: If I turn Social Gallery Pages off (I'd really like to use them by the way) I get the following message:

The object at 'http://benthies.de/' previously had type 'article' and cannot be changed to an object of type 'website' to avoid data corruption of existing action
So i assume that Social Gallery also sets og:type to 'website' instead of 'article' (which would be the better one for pictures and stuff in my opinion). Whatever, Facebook won't share my like without Social Gallery Pages turned on. But somehow I (or whatever it was) managed that facebook notices at least something when I like a picture having Pages turned on. But I'm not convinced yet because the link appearing on my facebook timeline still directs me to my start page and the one like I gave to a special picture made me like every picture in the gallery.
This issue is probably connected to the url-related og error. Any Ideas?

02-18-2013, 06:05 AM
Hey Deepabysm,

OK so I've taken your page benthies.de/social-gallery/little-thoughts and dug into it, both of the following blocks exist:

<meta property='og:locale' content='de_DE'/>
<meta property='fb:admins' content='100000048446823'/>
<meta property='og:title' content=''/>
<meta property='og:url' content=''/>
<meta property='og:site_name' content='Ben Thies'/>
<meta property='og:type' content='website'/>
<meta property='og:image' content='http://www.benthies.de/wp-content/uploads/logo.png'/>
<!-- / Yoast WordPress SEO plugin. -->

... this is at the top of your page html - as you can see from the trailing "/ Yoast" - it's probably Yoast's SEO plugin which is creating this

<meta property="fb:admins" content="100000048446823"/>
<meta property="og:title" content="Little Thoughts" />
<meta property="og:description" content="&quot;Little Thoughts&quot; by Ben Thies"/>
<meta property="og:url" content="http://benthies.de/social-gallery/little-thoughts"/>
<meta property="og:image" content="http://benthies.de/wp-content/gallery/flowers-trees-plants/little-thoughts.jpg"/>
<meta property="og:type" content="article"/>
<meta property="og:site_name" content="Ben Thies"/>

.... this is just before the closing </head> of your page and is the meta details created by Social Gallery

In this case I think Social Gallery is actually setting these correctly, it's simply the case that it deals with pages in a way that Yoast's plugin isn't expecting and so is causing it to output empty OG data. I've dug around a bit to try and find you a solution, but I think the best bet is for me to just roll it out in v2.1 so that anyone using Yoast get's the fix (if they want it.)

If you see here - http://wordpress.org/support/topic/plugin-wordpress-seo-by-yoast-cannot-remove-opengraph-meta-data-tags?replies=5 - it should be possible to simply override Yoast OG data via the template - you could do this yourself by going in to SocialGallery/templates/single-social-gallery-image.php and putting:

global $wpseo_og;

... just after the first "<?php" tag... that will *probably* do it. That or you can wait for a few days and I'll get it tested/rolled out in v2.1 :)

I think with regards og:type of "website" - you are probably right. In v2.1 or soon after I'll make the type choosable :)