PDA

View Full Version : Feature Request: Shortcode to Disable Social Gallery [Solved]



fotoglut
01-03-2013, 05:05 PM
Hi,

for better usability it would be great to have a Shortcode for disabling SG on Single Pages oder Blogentrys...

Example:
an the Page: fotoglut.de/fotogalerie/ i dont want a SG, because its an Overview Page for the Gallerys...

But if i play around with the CSS, it works all or nothing....

The Same is on the Forntpage of my site at this Moment, i try to make the Picture as a link to the Blogentry, but alway SG opens...

woods
01-09-2013, 03:34 PM
Hi fotoglut,

This already exists!

If you put <div class="noSocialGallery"> </div> around your content it wont show in social gallery :)

fotoglut
01-09-2013, 07:16 PM
Hi Woods,

thats works for me on normal Post, but not on NGG Overviews....

see on:
Fotogalerie/ (http://www.fotoglut.de/fotogalerie/)
the only content put in the Editor is: [album id=1 template=extend]

Some Idea, where to put in the "div class"
I Know, special Things ;-)

woods
01-10-2013, 03:10 PM
Hi fotoglut,

Awesome example page - I really like your use of cool images, Justified Image Grid and Social Gallery :)

You should be able to just wrap that shortcode in a div like:

<div class="noSocialGallery">[album id=1 template=extend]</div>

Does that solve your problem?

If you have it popping up for overviews you need to just add the overview class to "CSS Deselectors"?

fotoglut
01-10-2013, 09:17 PM
thank you for the compliment...

Sorry but i changed the Page between my Post and yours because my Visitors are wondering waths happend by clicking the Image...

The Page with the NGG Problem ist now here: fotoglut.de/testseite/ (Password = test).
At that moment the Code are: <div class="noSocialGallery">[album id=1 template=extend]</div>

And i dont change it, bevor you reply :-)

For testing i put in all the NGG- Classes at once and as single... .ngg-albumoverview .ngg-album .ngg-albumtitle .ngg-albumcontent .ngg-thumbnail
nothing works, always the Social Gallery pops up....

woods
01-11-2013, 05:19 AM
Hi fotoglut,

OK your best bet is to put the following in your "Deselector CSS" box in settings:

.Thumb, .ngg-thumbnail

... let me know if that solves this one :)