PDA

View Full Version : Image Sizes..



mstracylee
05-24-2013, 01:52 PM
How do I get social gallery to put the images the sizes that I upload them? Like you have in the dawn rises example? all of my photos default to 500somethingby 300 something I think...

mikemayhem3030
05-26-2013, 01:55 PM
Hi

I've never come across a problem here with image sizes, social gallery only views images, if they're going on your site at a different size than you upload them you'll have to figure out what setting on your install is causing it (it's not a social gallery issue)

Burken
05-26-2013, 03:12 PM
Hi there,

having a related question about IDEAL IMAGE SIZE for uploading

i run social gallery lightbox on top of NextGen:
www.AkashaYogaAcademy.com/media/photos

Before uploading my stock i would like to clarify the ideal size
settings for your lightbox:

1. pxl x pxl

2. ratio: specific ratio / format to have CONTINUOUS filling of entire screen
(left of social galleries RHS bar)

3. minimum pixel to fill the screen on all devices / particularities around MOBILES ?

4. 72 dpi - or is there any improvement when uploading slightly higher ?

5. should i scale the pics offline on my PC - or does social WP /
Nextgen / Social Gallery offer sufficient auto-resizing/scaling options?

THX A LOT for supporting - i sincerely appreciate it !!!

burken

“Smile, breathe and go slowly.”
- Thich Nhat Hanh


PS
details:

i have the FULL-screen lightbox of social gallery DEFAULT enabled.

my aim is a paradox: ;-)
transmit very crisp images across the screen
without slowing down the performance of my users who tend to have slow
connections.

the wordpress default setting of 800x600 seems to be slightly to low.
which settings would you recommend, considering the described situation?

mstracylee
05-27-2013, 04:44 PM
i kind of figured it out. I put the images up at 720x480. if i choose 100%, it shows the images at 500something... if I choose 130% it shows them close to size, but at a reduced quality although I uploaded at 100%quality. I feel like social gallery shows at the 500 size, enlarges up 130 % and the image is more poor quality than the original i upload. doesn't make sense why do it that way?

mikemayhem3030
05-28-2013, 08:41 AM
Social Gallery is a lightbox, it takes whatever image you have linked to (i.e. <a href = "large.jpg"><img src = "small.jpg" /></a> it then gives you the option of increasing the size of the large.jpg if you like.. It shouldn't open at 500 if you put the large image on the page at 720

mstracylee
05-31-2013, 06:51 PM
well I uploaded images at 720, and when the gallery is set to 100% it shows the images at 500. Please help?

mikemayhem3030
05-31-2013, 11:10 PM
Can you share a link plz

mstracylee
06-01-2013, 11:49 PM
Can you share a link plz

http://bboylifestyle.com/pictures/?album=1&gallery=165

The image is loaded at 720x480

and it's displaying at 572x382 according to the html

mikemayhem3030
06-02-2013, 05:40 PM
It looks to be... however you also have a nextgen lightbox loading up so I try disabling that first, it could be social gallery causing it but to be 100% sure can you try the same images, using the WordPress standard theme (twenty twelve) using the WordPress Gallery (create post, add media, create gallery and add link = "file" to the shortcode) if SG still shows those ones up smaller, have a look to see if you've set something in the "upscale box" to below 100%

mstracylee
06-02-2013, 08:20 PM
I turned on the light box for a totally different issue. I thought your plugin was supposed to automatically disable to light box if the option is checked, but it doesn't. People visiting the site on iphone can't see social gallery correctly because it isn't responsive so I had to turn it off for mobile. I still want them to be able to easily navigate the pics which is why I turned the other lightbox back on in Next gen, but SG isn't automatically turning it off..

I'm not quite sure I understand what you are asking me to do.. I'm not going to take down my site to the twenty/twelve theme. I can create a post on my existing theme with a wordpress gallery and test out a gallery if that's what you're asking me to do? what gallery mode do I choose in SG? Also, this issue has happened on any template, so it's not a template related thing. What "upscale box" are you referring to? the one in the SG plugin?

mstracylee
06-02-2013, 08:33 PM
I added a post using the wordpress gallery and changed the gallery setting in SG to post. I also added link = "file" to the short code and SG came up with the photos still resized.. The thing is, it's a quirky resize issue. If I right click to inspect element, the gallery automatically resizes it bigger. Another quirky this is if you use the arrows on the top right to go to full screen more, then use the arrows on the keyboard to the right, then it plays the photo at the correct size. once you take it out of full screen mode then it goes back down to the resized images.. I would like it to run at not fulkl screen but show the correct size images as your "dawn rises " demo shows...

mikemayhem3030
06-02-2013, 08:43 PM
Hmmm interesting, I didn't mean your live site, you can test on a test site / subdomain to help debug (it's what I do with my plugins)... have you bought the social gallery mobile add on? they make mobile much better.

I'm afraid I'm a bit stuck with the image resizing, I'll have to check with Woods and get back to you

tomdaams
06-03-2013, 12:29 AM
this is just like the problem I had. Can you make a gallery that you will let be so i can look at it for you?
Because:http://bboylifestyle.com/pictures/?album=1&gallery=165
is loading double/dual lightbox's?

It looks like your working on it as we speak?

tomdaams
06-03-2013, 12:30 AM
Oh and please make it a page with small page load. Im on a very slow connection so checking a page with a lot of pix takes a lot of time for me...

edit;
Yeah you can temp fix the double lightbox thing by adding custom CSS to NextGen:
div#shShutter, div#shDisplay {
position: inherit;
}

but i dont know if you just missed a checkbox or ur making changes and this is a temp effect

tomdaams
06-03-2013, 12:41 AM
Haha wow, i completely forgot what I was working on after replying here.. omg...

(Mike, im not always so damned weird and chaotic like the way im now btw ;P just felt like excusing myself hehe)

mikemayhem3030
06-03-2013, 07:39 AM
Any help on the forum is more than appreciated tom :) I've added you some reputation points for being helpful - cheers

tomdaams
06-03-2013, 05:19 PM
I just want a damn 'share' button man :P

But cheers, is it time to let people BOW before me now??? :D

nah, j/k. Didnt became a war photographer because of 'benefits', i just love to help out man :)

mstracylee
06-03-2013, 07:52 PM
this is just like the problem I had. Can you make a gallery that you will let be so i can look at it for you?
Because:http://bboylifestyle.com/pictures/?album=1&gallery=165
is loading double/dual lightbox's?

It looks like your working on it as we speak?

I gace the reason above why I have two light boxes..

mstracylee
06-03-2013, 08:20 PM
Hmmm interesting, I didn't mean your live site, you can test on a test site / subdomain to help debug (it's what I do with my plugins)... have you bought the social gallery mobile add on? they make mobile much better.

I'm afraid I'm a bit stuck with the image resizing, I'll have to check with Woods and get back to you

that means I would have to load an entire site up just to test? i will see if I can or not.

I haven't bought the mobile add on, will it make it responsive? I definitely will if that's the case..

Any ideas on the quirky resizing issue?

mstracylee
06-03-2013, 08:22 PM
Oh and please make it a page with small page load. Im on a very slow connection so checking a page with a lot of pix takes a lot of time for me...

edit;
Yeah you can temp fix the double lightbox thing by adding custom CSS to NextGen:
div#shShutter, div#shDisplay {
position: inherit;
}

but i dont know if you just missed a checkbox or ur making changes and this is a temp effect

it's social gallery causing the double light box in my opinion. Ih ave checked "disable next gen effect" and its clearly not working. I want a light box on for Mobile, as SG isn't responsive when mobile...

mikemayhem3030
06-03-2013, 09:14 PM
Check out the main site viewed on a mobile or tablet for how the mobile add on works :)

mstracylee
06-14-2013, 06:39 PM
that looks great but completely defeats the purpose of why I have social gallery in the 1st place.

Can you please help with why the image sizes are doing what they do? Also why when the "Automatically disable NextGen Effect" is on, it's not disabling?

And last, in the light box on your main site, the box is huge, and the iframe for comments doesn't have scrollers, yet the one on my site does.


help?

mikemayhem3030
06-16-2013, 10:32 PM
Hi

I'm not sure on the image sizes I'm afraid, It's something I'm looking into but since Woods did the dev on this it's something he's going to have to look into for me (he's away till mid July).

Re the scrollbox, this will be some CSS on your site, I can take a look for you

mstracylee
06-25-2013, 05:34 PM
why do you offer a check box to have social gallery automatically turn off the effects? I'm confused by that because it clearly doesn't work.

As of the sizes, I am super frustrated by this. :(

mstracylee
06-25-2013, 05:34 PM
especially since I have now uploaded larger size photos to see if that made any difference and it hasn't..

mikemayhem3030
06-28-2013, 05:36 PM
The check box does work...

Have you tried toms reply number 9 here: http://forum.socialgalleryplugin.com/showthread.php/293-pop-up-box-size-is-stuck

mstracylee
07-12-2013, 02:05 PM
ok, one issue solved, thank you..

what about the box that says it turns off the next gen gallery effects? this check box doesn't work, which is why I have social gallery AND a light box going.. the light box I have for mobile for now, but the social gallery i have for desktops.

Realistically, I would like social gallery to be responsive for mobile. and still have the social gallery features to it. Is that going to come in the near future? I realize you have a mobile add on, but it doesn't have the social gallery features to it..

thank you...

mikemayhem3030
07-12-2013, 05:49 PM
Hi this should help with the lightbox? it's for the Lite version but should still hold

http://www.nextgen-gallery.com/social-gallery-lite/

The mobile add on definitely does have the social features, check out the main site on an iPad for example (or a iPhone - you may need to have the iphone side on???) as you may have seen I've taken over SGP going forwards

It's going to take me a bit of time to fully get up to speed with the coding behind the plugins (as they're about 200 hours of work) but I'll get there and then drive them forwards

mstracylee
07-14-2013, 05:48 PM
Hi this should help with the lightbox? it's for the Lite version but should still hold

http://www.nextgen-gallery.com/social-gallery-lite/

The mobile add on definitely does have the social features, check out the main site on an iPad for example (or a iPhone - you may need to have the iphone side on???) as you may have seen I've taken over SGP going forwards

It's going to take me a bit of time to fully get up to speed with the coding behind the plugins (as they're about 200 hours of work) but I'll get there and then drive them forwards

Social gallery doesn't work on my brand new Galaxy s4.. Your home page half the photos don't bring up the mobile version and half do. Once on the mobile version, it stays there for about 2 seconds and then backs out to the main page so you can't see the enlarged photo. The ones that don't bring up the plugin, take you to an attachment page where the photo is the size of a tiny thumbnail instead.

Neither of them has the social features though..

Just tested your site on my ipad too.. You may want to check whats going on with it. Same issues on the ipad too..

mikemayhem3030
07-15-2013, 08:36 AM
Hmm I will check what's going on with it and get back to you, it worked the last time I checked it

bigfootwebla
09-08-2013, 03:07 PM
this is definitely a bug.

removing max-width: 100% from your stylesheet (while it works) only serves to break your theme's layout for other images.

Sometimes my lightbox gets stuck on certain images and displays them smaller, clicking fullscreen does nothing.

Other times, clicking fullscreen, then cycling in fullscreen forces the images to be displayed in their max size. It's very inconsistent.

Can we get another look into this, it's driving me insane, as I'd like to have my photos displayed at thier max size to fill the screen.

mikemayhem3030
09-13-2013, 08:46 AM
Hi again

Can you check to see if you're still having the issues on socialgalleryplugin.com when viewing on mobile + tablet? as for galaxy S4 that's a newer handset and the mobile plugin needs updating to capture the very latest phones (we are working on SGP v3.0 development now) so hoping to fix these bugs.

I tried on my iPhone 5, and it works OK, although the social stuff was only visible in landscape of the phone orientation (the mobile is still in beta and we're working on this too as part of SGP v3.0 dev) it's very complex though and not as simple as other lightboxes

Please do be patient as custom themes can mess with things unfortunately - we are doing our best.

mstracylee
10-29-2013, 11:11 PM
Sorry- I just saw your reply.. now the show gallery on off switch works, but when I go to turn it on to test it for you, i get a page can't be displayed on my own admin page. every time I try it. I have the tablet one set to on, and social gallery isn't showing on my ipad..

www.combatlifestyle.com

I had to stop using the plugin when my site got high traffic a few weeks ago because it crashed my site over and over.. There may be a memory leak of some kind??

I want this plugin to work for me so bad but i'm a high end user and it doesn't seem to work for my needs..

mikemayhem3030
10-30-2013, 09:03 AM
Hi

I'm not sure where the leak could be if any, how many images are you hosting? Can you put it back up on a test site perhaps or a clone site so I can help out

mstracylee
11-08-2013, 11:36 PM
When I finally get all my images up I will be at over 200k.. It's not NEARLY that many right now.. I can't say how many but I'm around 300 galleries uploaded versus the 4k or more I have in total

mstracylee
11-08-2013, 11:37 PM
I had brought the attention of a memory leak issue previously and they supposedly fixed it-prior to your taking over the software..

mikemayhem3030
11-10-2013, 10:43 AM
Hi, is it back?

mstracylee
11-10-2013, 09:02 PM
Hi, is it back?


yes, I turned it back on...

mstracylee
11-10-2013, 09:48 PM
Hi, is it back?

but I am still unable to turn on the option for mobile devices. when I choose that and hit save it directs me to a 404 page...

mikemayhem3030
11-11-2013, 07:55 AM
I'm not sure what you're asking about sorry, please post up a new thread

mstracylee
11-11-2013, 08:16 AM
I'm not sure what you're asking about sorry, please post up a new thread


Why would I post a new thread when it's all the same stuff we've been talking about???

mstracylee
11-11-2013, 08:18 AM
I turned the plugin back on as you asked. It won't work on mobile because the little thing that says "Show Social Gallery on Mobile Devices" well, when you turn it on, and hit save, it goes to a 404 page and doesn't turn it on.

mikemayhem3030
11-11-2013, 08:24 AM
You mentioned about a memory leak?

mstracylee
11-11-2013, 08:31 AM
I mentioned the memory leak as the reason that I shut down the Plugin. I'm going to assume that you have no high end users like myself. it doesn't work well for someone with high traffic and lots of photos. I have been trying to get many issues fixed for months and have yet to. It's pretty frustrating.

mikemayhem3030
11-11-2013, 08:39 AM
Hi

Of course we have high end users, can you repeat any issues in a new thread. That way it's all in one place and I'll look into each one and let you know what the reasons are

Thanks

Mike

mstracylee
11-11-2013, 08:51 AM
so you want me to put everything into one thread as I have here or you are asking me to put each issue in a separate thread?

mikemayhem3030
11-11-2013, 09:04 AM
Well this thread is confusing, the title is images sizes and it's now 3 pages with various contributors, if you're still having issues with v3.5 of Social Gallery put them all in one new place and I'll pick them up seperate to this

Thanks

Mike

mstracylee
11-11-2013, 09:07 AM
I have version 3.0. According to my codecanyon, that's the newest stable version you have.

mikemayhem3030
11-11-2013, 09:13 AM
It's version 3.1 on CodeCanyon which includes new update code as all future updates are handled by the Epic Update Core

Please do read the changelog

http://codecanyon.net/item/social-gallery-wordpress-photo-viewer-plugin/2665332

mstracylee
11-11-2013, 09:13 AM
And now my website just notified me of version 3.1?

mikemayhem3030
11-11-2013, 09:23 AM
Has it? If so you download v3.1 and then follow the steps for future updates, this is because

1.) We can push out new updates much easier (currently we update and codecanyon can take up to a week to approve)
2.) It's easier for the user too - no more going to CodeCanyon, redownloading, etc it's all handled just like wordpress.org plugins

Cheers

mstracylee
11-11-2013, 09:45 AM
Yes, it made me go to Codecanyon to download it so I did and installed it. I also created a new thread with all the issues..