PDA

View Full Version : Justified image grid problems



bentatts
05-08-2013, 03:36 AM
I've loaded social gallery up and paired it with justified image grid and when I click on an image it begins to load then opens the image in the parent window full screen instead of in the lightbox. Tried all sorts of different things anyone have any ideas? Here's a link to the page http://backtoschoolies.com/gold-coast/photos/

mikemayhem3030
05-09-2013, 10:38 PM
Hi

It doesn't look like you've got Social Gallery running, so apologies I can't see any errors to help to fix with.

bentatts
05-09-2013, 10:46 PM
Sorry Mike I disabled it while it wasn't working. Have just set it back up now :)

bentatts
05-09-2013, 10:48 PM
I've tried all different types of settings and configurations between the two plugins and keep coming to the same problem where the SG plugin begins to fire then the image url opens instead.

mikemayhem3030
05-09-2013, 10:53 PM
Hmm it's a weird one, first of all can you look at disabling any plugins that may mess with effects (you have a lot of javascript going on on your pages). In particular jquery cycle?

[cycle2] --c2 init-- jquery.cycle2.js:573
[cycle2] fx: scrollHorz (string) jquery.cycle2.js:573
[cycle2] slides: > div (string) jquery.cycle2.js:573
[cycle2] timeout: 5000 (number) jquery.cycle2.js:573
[cycle2] speed: 2000 (number) jquery.cycle2.js:573
[cycle2] pauseOnHover: true (boolean) jquery.cycle2.js:573
[cycle2] pager: #no-template-pager (string) jquery.cycle2.js:573
[cycle2] pagerTemplate: (string) jquery.cycle2.js:573
[cycle2] --c2 init-- jquery.cycle2.js:573
[cycle2] fx: scrollHorz (string) jquery.cycle2.js:573
[cycle2] pauseOnHover: true (boolean) jquery.cycle2.js:573
[cycle2] speed: 1000 (number) jquery.cycle2.js:573
[cycle2] slides: > div (string) jquery.cycle2.js:573
Given URL is not permitted by the application configuration.: One or more of the given URLs is not allowed by the App's settings. It must match the Website URL or Canvas URL, or the domain must be a subdomain of one of the App's domains.

There's also the facebook warning here:

Given URL is not permitted by the application configuration.: One or more of the given URLs is not allowed by the App's settings. It must match the Website URL or Canvas URL, or the domain must be a subdomain of one of the App's domains.

Can you try and fix this (by setting up your facebook app for the domain you're using (and making sure website with facebook login is selected with your URL).

If all that still causes a problem, what settings are you using? All content images? or something else? You could look into specific CSS selectors and input

.justified-image-grid a:has(img)

into the settings

My other suggestions would be...

Does it work when you use WordPress in post galleries (make sure you have link = "file" in the shortcode when you add media to a post and "create gallery")

Apart from that, my guess is other plugins fooling around with SG..

Let me know where you get to