PDA

View Full Version : Are likes suppose to show on Facebook when using adsense feature



raytronx
05-07-2013, 05:10 AM
Hello, I know the comments don't work but do the likes show up on Facebook when using the Adsense in SG? Just wondering before I spend time troubleshooting my Facebook setup.



Couple other issues I had installing the plugin just as feedback.

It would not complete the full scan, got stuck a 85 of 133. Deactivated a bunch of plugins and it finished the scan, not sure which was causing it.

Once it completed the scan the SG lightbox wouldn't work on all the images. I have regular WordPress post images, NextGen Galleries and Justified Image Grid. It would work on each when selected but not when set for all content images. I had previously used Pinterest Lightbox so reinstalled and all worked, then deactivated and went back to troubleshoot SG and suddenly everything worked, I get the SG lightbox for all images now just by doing a activate and deactivate of Pinterest Lightbox, weird.

The Social Gallery Pages template was messed up using my InReview Elegant theme so I had to customize it to get it working properly.

Anyway its a great plugin and really like the look of it, thanks

Ray
http://LoveYourRV.com

raytronx
05-25-2013, 06:51 PM
Anyone else using SG with the Adsense option? Do your likes show up on Facebook?

mikemayhem3030
05-26-2013, 02:09 PM
They should show up Ray :) not sure why they wouldn't.. I don't use the ads though

raytronx
05-26-2013, 04:35 PM
Thanks Mike,

I played around with it a little this morning and actually a few images were able to get a like in my Facebook activity, but most did nothing. They always show as being liked in the SG LiteBox but seems to be hit and miss on Facebook. Also the ones that get the like on Facebook, the link goes to just the image and not an SG page.

At least I know it is capable of talking to Facebook, so when I get a little more time will troubleshoot and report back my findings.

Thanks Ray

mikemayhem3030
05-26-2013, 04:52 PM
Cheers Ray

Yeah Facebook decides what it shows so we can't help there, the image link - it will go back to the social gallery page

http://www.socialgalleryplugin.com/social-gallery-pages/

Have you read the guides?

http://www.socialgalleryplugin.com/social-gallery-user-guides/

raytronx
06-14-2013, 04:38 AM
Well had a chance to troubleshoot further. It seems what is messing up my connect to Facebook through SG page is OG Meta data. I'm using Yoast SEO for that task on my site and it causes double OG Meta entries which in turn causes the grief with Facebook. If I disable Yoast FB OG setting the SG works right with FaceBook. But I still need Yoast SEO for all my other Facebook likes and shares on my posts. Do you think there is a way to disable Yoast just on the SG pages?
Ive tried a few other Facebook OG plugins and they seem to conflict the same way.

Ray

mikemayhem3030
06-14-2013, 06:25 AM
Hi

You can look at the template for the social gallery pages (check out the guide on how to edit:http://www.socialgalleryplugin.com/social-gallery-user-guides/) and then maybe look into this?

http://kynatro.com/blog/2011/05/24/disable-plugins-on-a-single-postpage-in-wordpress/

raytronx
06-15-2013, 12:13 AM
Thanks Mike, I think I'll leave it be, it's mostly working, last thing I need is another plugin to disable plugins. Wait and see if these social media sites and the plugin developers can get open graph a little more sorted out. Everyone is all over the map. Even Twitter and Pin it sometimes pick the SG page to link back and sometimes its just the image. Tumblr show blank stuff. Gplus pulls the home page. *shrug*

mikemayhem3030
06-16-2013, 10:37 PM
Raytronx

If they're not sending the page URL, it's either because

1.) The scan hasn't updated for you
2.) The image is in more than one place (but again should be fixed by doing a new scan).

As long as you're all scanned and up to date the shares on FB should be the rich og:meta type, but I agree it can be hit and miss with FB and the like