PDA

View Full Version : V2.2 Not working on WP 3.2.1 and Nextgen Gallery 1.8.4



shaq
04-20-2013, 03:08 PM
Hi,

I have been trying to use your plugin to no avail. It seems to not detect any of the nextgen galleries (1718images in 23 Galleries) no matter what options I choose.

I have it setup in Nextgen Compatibility Mode.

Site is http://

Please advise.

You can choose channels then photos to see the issue.

Thank you,


ADDED:There is a javascript error from SG javascript.


TypeError: jQuery(...).text(...).html is not a function
site url/plugins/social-gallery-wordpress-photo-viewer-plugin/js/socialGalleryPlugin.js
Line 9

mikemayhem3030
04-21-2013, 09:22 AM
Hello

Why are you using v3.2.1 and not v3.5? This could be down to an older jQuery version. You should upgrade WordPress because newer versions include all the latest versions of jQuery and other jQuery libraries.

shaq
04-21-2013, 11:49 AM
Hello

Why are you using v3.2.1 and not v3.5? This could be down to an older jQuery version. You should upgrade WordPress because newer versions include all the latest versions of jQuery and other jQuery libraries.

Thank you for the reply. The plugin works great on the new wordpress and nextgen but unfortunately I am stuck at 3.2.1 for this specific site. A lot of changes were done to wordpress core files by the previous web developer and an upgrade is not an option since also the theme utilized isnt compatible with WP 3.5. This plugin is supposed to be compatible from wordpress 3.1 and later.

I was also thinking that an older version of jquery was the cause due to the javascript error. I disabled all plugins that caused errors in javascript. I can't find the call to jquery anywhere to change it to 1.8

Any help would be greatly appreciated.

mikemayhem3030
04-21-2013, 12:18 PM
It usually is compatible with older WordPress, your issue is most likely to do with the heavily modified core files. I wouldn't have thought a developer should need to modify core files especially with as many hooks and filters available but I won't get into that :)

You could add a line in the bottom of your theme header? to add the latest version of jQuery as a quick test, try the Google hosted one for a start?

shaq
04-21-2013, 12:52 PM
I tried adding a call to jquery 1.9.1 and 1.8 but both resulted in breaking my nivoslider since it is using
<script type="text/javascript" src="http:// siteurl /wp-content/themes/eshopper/js/jquery.nivo.slider.pack.js"></script>

The nivo slider on homepage stopped loading with javascript unknown function nivoslider
Also the nextgen gallery gets the shutter effect disabled without SG taking over.

shaq
04-21-2013, 12:55 PM
Should I include the jquery (1.8?) in the beginning on the socialGalleryPlugin.js to make sure it is loaded when needed by the plugin?

shaq
04-21-2013, 01:00 PM
Ok. I got it working by including jquery 1.9 in the socialGalleryPlugin.js
Now my nivoslider is broken on the homepage but I think I can figure it out. ---FIXED by using 1.8 jquery for nivo slider, socialGelleryPlugin and nextgen gallery.

Thank you for leading me to the solution!

How do I mark this as Resolved?

mikemayhem3030
04-21-2013, 09:17 PM
Hello

Cheers for this, glad you've got it sorted. I've had similar issues with some of my plugins (on others sites) who are running old versions of WordPress. It's like those people who still play on a PSone because it's been chipped ;)

Good Q regarding the resolved, I don't know :)