PDA

View Full Version : "Show Image Title as Description" doesn't work



Sara
04-16-2013, 11:59 PM
I just upgraded from SG 1.4 to 2.2. Previously, the plugin did pull the titles from the img title tag without problem, and all my laborious titling of 300++ images in NGG paid off nicely.

However, despite the misleading option label in the settings, version 2.2 does not pull the share description from the img title tag. It is looking for the link's title tag. (I suspect this has something to do with Social Gallery Pages?) So with SG Pages enabled, the "Show Image Title as Description" option is worthless because I cannot set the link title tag from within NextGen Gallery. :(

However, it will pull from the description that you set in NextGen Gallery when the option is ticked. :confused: But this means I have to go through every image in every gallery and manually copy the titles into the description box for the description to share properly.

Am I missing something? Please help!

Thanks

mikemayhem3030
04-17-2013, 05:43 AM
Hi Sara

I've not come across this one before, I'll look into it however I suspect it's something to do with making SG "future proof" as I think WordPress have removed img title tags

http://wordpress.org/support/topic/title-tags-for-images?replies=5

Giovanni
04-17-2013, 10:25 AM
Hi all, i've the same problem. After the upgrade to v 2.2, in the SG window, i can't see the description and title of the ngg images... what happened?

mikemayhem3030
04-17-2013, 12:23 PM
I'll check in with Woods and let you know what the deal is.

Giovanni
04-17-2013, 03:08 PM
I'll check in with Woods and let you know what the deal is.

Hi, after tue upgrade of Social Gallery, i've also a problem when I publish a post, it says me:

Fatal error: Cannot redeclare file_get_html() (previously declared in /web/htdocs/www.discoverycilento.it/home/wp-content/plugins/lightbox-plus/classes/shd.class.php:82) in /web/htdocs/www.[...]/includes/simple_html_dom.php on line 85

Can you help me?

Giovanni
04-17-2013, 03:23 PM
I use WordPress 3.4.2. , I get this error only when I publish a post, with a blank page, not when I publish a page. What can I do?

Sara
04-17-2013, 07:13 PM
Any news?:D

mikemayhem3030
04-18-2013, 10:02 PM
No news I'm afraid, any future development of this plugin isn't planned until later in the year. At the moment there are plenty of manual work arounds (such as adding image titles to links etc) but nothing in the way of a "quick fix" unfortunately.

@Giovanni Fatal error: Cannot redeclare file_get_html() (previously declared in /web/htdocs/www.discoverycilento.it/home/wp-content/plugins/lightbox-plus/classes/shd.class.php:82) in /web/htdocs/www.[...]/includes/simple_html_dom.php on line 85

Just seems to be a function clash between two plugins you have running, do you need them both?

Giovanni
04-18-2013, 10:09 PM
Hi mikemayhem3030,

yes, thank' u!! The problem remains :\ Can you help me?

mikemayhem3030
04-18-2013, 10:16 PM
It's a function clash, you can't fix it unless you delete one of the functions, I don't know the location of the other link (it's got [....] in it) what plugin is this? If they're both Social Gallery, please make sure you've fully deleted any prior version and try a fresh install (it could be you have an old version still alive somewhere).

Cheers

mikemayhem3030
04-18-2013, 10:17 PM
Actually

plugins/lightbox-plus

The conflict is caused by the lightbox-plus plugn - can you remove this? with Social Gallery running having a different lightbox is silly