PDA

View Full Version : Featured images open with Social Gallery although they shouldn't



cursillos
03-19-2013, 04:52 PM
Hello,

I have purchased and installed social gallery in www.cursillosmadrid.org/wordpress
In the Home page there are posts that have a featured image, but only the posts that have the format "image" should open the image when you click on them.
However, if you click on the featured image of a post that has a "standard" format, it tries to open the image with social gallery but after a second it closes and if you try again then it opens the post. You can try with the last post titled "prueba de newsletter", it has a "standard" format and it shouldn't open the image when you click on it.
The theme is called PINBOARD.
And you can also try the post called "Aitor de la morena" that has an "image" format and you will see it correctly opens the image with social gallery. Here it works ok.

Thank you.

cybohmoob
03-19-2013, 07:13 PM
In SG options set to Load using custom Class Selector. Save option so custom BOX APPEARS.

Now create a Selector. Example .LoadSg with "." period note:Don't use things like .image or .lightbox ect. Those are sometimes used by all kinds of other plugins and such.

Next insert LoadSg into the CLASS box in image Advanced without the "." period. Now you can choose ANYTHING to load as long as you add LoadSg . It could be featured. It could be Avatars. It could be anything really as long as it has LoadSg.

All other images will not load SG if you don't give it a LoadSg Class Selector in the Image Advance options CSS box. Plain and simple.



You can also use a disclude Class Selector . Example is .NoSg with "." period note: This option is only really used for some stubborn PLUGINS that may have accidentally chosen to use the SAME Class Selector as your LoadSg or uses some rogue coding that SG is misinterpreting as LoadSg . What are the chances of this happening? SOmetimes it does.

Entering NoSg without "." into the Class Box in image Advanced will make that image ignored by SG. Period.

---------------------------------------
This is the strongest method I enjoy using in Social Gallery and the only method I recommend because it ONLY LOADS things with the class selector I have chosen. Nothing else.
It allows me to control Exactly what I want loaded and not load exactly what I don't want.
---------------------------------------
Note: If you have good CSS, PHP, JS and html skills you could even HardCode the class selector into them and EVERYTHING they load will let SG LightBox it.

All other modes I don't recommend because they will sometimes load things you don't NEED and you get a SG screen without any pic so Custom Class Selector is the way to go imo.

matthew
03-21-2013, 01:02 PM
Hi cursillos,

Do you still require some help with this?

Thanks,

Matthew

cursillos
05-09-2013, 10:39 AM
thanks Matthew,

I solved the problem by adding the following code in the "Disclude CSS Selector":
.entry-thumbnail a:has(img)

And it works.

mikemayhem3030
05-09-2013, 11:42 PM
Cool :) glad it's working

bluebird
07-27-2013, 01:23 PM
I had the same problem and I solved it as @cursillos did it by "adding the following code in the "Disclude CSS Selector": .entry-thumbnail a:has(img)"!

mikemayhem3030
08-15-2013, 07:54 AM
Awesome glad the forum is proving useful :)