View Full Version : Gallery Closes after split second.

03-11-2013, 12:20 AM
I purchased social gallery +plugins due on 13th, Justified Image Grid & recommended sprout-magazine theme.

Many times when clicking images the Social Gallery box pops up for a split second then closes, after a few more clicks just the image opens.

eg. standard gallery. http://ci.je/demo/galleries/ social gallery flashes up then closes.

Also is there a way to stop social gallery opening full screen eg. http://ci.je/plemont-bay-jersey/ all images seem to be full screen rather than image size.



It may be due to a broken link on plugin config
You have recently enabled Social Gallery Pages, for this feature to be fully enabled please Run a Scan Now
You do not have sufficient permissions to access this page.

Whats the correct url? >

03-11-2013, 01:30 PM
Hi Gavo,

Thanks for purchasing and posting here!

With regards your first problem. That occurs when your image links are pointing to attachment pages/URLS which are not image media links. To fix this make sure your images are linking to the actual media (image file) not an attachment page. Let me know if you need help with this!

With regards the broken link - that's a bug in v2.0 that'll be fixed this week when I release v2.1 - you can achieve a full scan by going to "Update Engine" and completing a full scan.

With regards full screen settings - the size of your images / mode of Social Gallery depends on 1. how large a resolution you upload images and 2. your settings under "Margins" and "Fullscreen mode" in the settings.

Hope this helps, please do let us know how you get on!

03-15-2013, 10:35 PM
Thanks I upgraded and the size of the image box size seems good now & I see the options for it.
I should have figured out about uploading images myself, im a little rusty with wordpress :)

The update engine doesn't seem to finish

And image library has an error.
Fatal error: Call to a member function get() on a non-object in /home/cije/public_html/wp-content/plugins/codecanyon-2665332-social-gallery-wordpress-photo-viewer-plugin/includes/SocialGallery.Library.php on line 164

Is there a way to disable the plugin for related posts? when clicking a thumbnail it opens the lightbox with no image. eg. http://ci.je/plemont-bay-jersey/


03-17-2013, 04:42 PM
Hi Gavo34,

We're currently investigating the error you provided above, please bear with us while we investigate.

With regard to your question about disabling the plugin for your related posts, please try entering '.related img' (without quote marks) within your Social Gallery settings (under General -> Disclude CSS Selector).

Thanks for your patience.


03-17-2013, 07:11 PM
I am currently having the same error with the image library, and my gallery closing immediately (only for a new post I added since upgrading)
Furthermore, I cannot disable the Social Gallery even if I tick this option. So. until I get this resolved I cannot publish this post or I must avoid using galleries.

03-18-2013, 12:16 AM
Hi jrlefrancois,

Sorry to hear you are experiencing the same issue. We're currently investigating this and will report back soon.

Thanks for your patience with this.


03-18-2013, 12:23 AM
Hi jrlefrancois,

Sorry to hear you are experiencing the same issue. We're currently investigating this and will report back soon.

Thanks for your patience with this.


No worries. It ended up working in the end. I think I put it to "compatibility mode" I think this was the only option that worked for me.

For reference: http://appetize.ca/2013/03/17/giveaway-win-a-set-of-abeego-flats/

03-18-2013, 12:36 AM
That's great news! It does look like there are a few bugs with the newest update. Please rest assured we will address any issues ASAP.

Thanks for letting us know.


08-31-2013, 10:28 AM
I changed my gallery links from attachment to images and it worked so that does solve the problem

But i have a missing link also

just purchased this today latest version 2.3

The missing link is

Warning: file_get_contents(http://www.socialgalleryplugin.com/updateEngine/?ori= [function.file-get-contents]: failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found in B:\xampp\htdocs\wordpress\wp-content\plugins\socialmedia\SocialGallery.php on line 3027

But it seems the plugin is working without it thanks

09-02-2013, 06:07 PM
Not sure what that error is, I'm working on the next update of Social Gallery from next week so hopefully all little bugs will be ironed out

09-02-2013, 07:37 PM
great ill wait for that lots of bugs at the moment

09-06-2013, 08:34 AM
What bugs are you referring to? Also can you check if allow_url_fopen is set to no on your site.