PDA

View Full Version : Changing blog URL effects Social Gallery Pages



ryansaw
03-02-2013, 04:05 PM
I own Babyanimalz.com and the Social Gallery (Page) is pointing to the wrong directory.

Let me try to explain. WP is installed under babyanimalz.com/blog but I use an htaccess file so that it rewrites WP to the main directory. All the other plugins I have installed work fine, but the Social Gallery The actual page it creates for each image is pointing to babyanimalz.com/blog/social-gallery/imagename which results in a page not found. If I remove blog from the URL it works fine. Currently, I have the Social Gallery page disabled and it is working fine, but I would really like to be able to utilize the Gallery page. How do I get the plugin to point to the root directory (remove the blog directory in the image link?)

Hope there is an easy fix.

Sincerely,

Ryan Sawyer

woods
03-05-2013, 07:59 AM
Hi Ryan,

Interesting case, thanks for posting.

Social Gallery (http://www.socialgalleryplugin.com) uses your blogs setting for ROOT, that is - what your blog option thinks is it's web address. To fix this you'll just need to set the blog site URL to the correct one (without the /blog/) - you'll need to do this under settings and perhaps more generally in your database, I think you may experience other problems if you continue to run it from a subdirectory, unless you tell WordPress itself.

Anyhow here's the WP.org guide to changing your site url (http://codex.wordpress.org/Changing_The_Site_URL).

Please do let me know if that doesn't solve it!

bentleykf
03-13-2013, 03:43 AM
Possibly related,

just noticed that the social header links point to the location of my wordpress install and not the location of my blog or my site.
This occurs using either the Site Img & Link, or Site Link option under Social Header Type.
Wordpress Address: https://www.mysite.com/wordpress/
Site Address: https://www.mysite.com/
Blog Address: https://www.mysite.com/blog/

Also noticed that it doesn't detect ssl, so you'd have to change the addresses to https in settings -> general.

It might be better to use home_url() instead of get_bloginfo('wpurl') just for the site link and have user input to override the url in social gallery settings. I'd also suggest site_url() for other applications of sgp_bU

matthew
03-21-2013, 11:49 AM
Hi bentleykf,

Thanks for the info. I've passed this on to Woody to consider for a future update.

ryansaw, If you're going to change your .htaccess to rewrite your URL's, then you may also need to add more rewrite rules for other plugins if using WordPress in a non-standard way. Please review the link that woods sent and also take a look here:
http://codex.wordpress.org/Moving_WordPress


Thanks,

Matthew

woods
03-25-2013, 03:02 PM
Hey All,

@bentleykf, good shout - I'll do this for v2.2 tomorrow. Thanks for suggesting.



W